Using Microsoft Office to Manage Projects
(or, Why You Don’t Need MS Project)

Using Microsoft Office to Manage Projects will explain how to use two applications in the Microsoft Office suite to document your project plan and assign and track tasks. Basic project management techniques are not covered. If you would like to develop skills in project management many colleges and universities have such courses in their business programs and continuing education services. You can also try www.primelearning.com for an online course in Fundamentals of Project Management.

Contents

Project Planning with Excel ........................................................................................................... 2
  Getting Started ......................................................................................................................... 2
  Quick Tour .............................................................................................................................. 2
    Basics .................................................................................................................................. 2
    Planning Grid ......................................................................................................................... 3
    Gantt Chart ........................................................................................................................... 3
Task Management in Outlook ....................................................................................................... 5
  Set up ....................................................................................................................................... 5
  Creating Tasks .......................................................................................................................... 6
  Assigning and Tracking Tasks .................................................................................................. 8
  Communicating Progress ......................................................................................................... 11
Moving Tasks from Excel to Outlook .......................................................................................... 13
  The Easier Way ....................................................................................................................... 13
  The Harder Way ..................................................................................................................... 20

Printing note: this document is formatted to print double-sided. Please save paper.
Project Planning with Excel

Many people today use sophisticated project planning tools like Microsoft Project to define activities and assign tasks. These tools also allow project managers and teams to visualize the scale and timeline of their projects. MS Project is, however, expensive to deploy. It is also not very intuitive to use. Most people use it for the planning grid and the Gantt chart view. Most of the features of the program remain unused. Our Excel spreadsheet, Project_Template, has the planning grid and Gantt chart view. It does not link dependent tasks or automatically adjust start and end times, though.

Getting Started

Find the template, Project_Template_03.xls in the Excellence folder on Fileserver, in the subfolder called ‘Projects’. You can also open it by clicking on this hyperlink, Fileserver\Excellence\Projects\Project_Template_03.xls.

Immediately save the file under a different name and place it, through the Browse window, in a folder where your project information resides.

Quick Tour

Basics

The spreadsheet will support 300 tasks over six months. If your project requires more of either, consider using different spreadsheets for each phase of your project or getting Microsoft Project.

Because there are many fields with calculations and they depend on specific data formats to work, most of the cells in the spreadsheet are locked. This means you will not be able to accidentally type over a calculation. The cells where you will be entering information in the planning grid are not locked. Although the spreadsheet is protected, you will still be able to sort and auto-filter in the planning grid. Date fields require a date format in a specific range or will return an error.

Column names and status values are consistent with the Tasks component in Microsoft Outlook. This facilitates importing tasks from the Excel spreadsheet into Outlook. For details on how do this, see the chapter on ‘Moving Tasks from Excel to Outlook’.
Printing has been pre-formatted. Preview the print job by using File > Print from the menu bar instead of the printer icon in the toolbar to see how many and which pages will actually have information on them and choose those to reduce wasted paper and time.

Planning Grid
Task information is entered in the planning grid. The template has some information filled in as a reminder of how to use the tool. This information can be selected and cleared. There are eight columns in the planning grid section. They are explained in the table below.

<table>
<thead>
<tr>
<th>Column Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Num</td>
<td>Allows a number or character to be entered to track task order. Can also be used to enter the Work Breakdown Structure (WBS) code. (optional)</td>
</tr>
<tr>
<td>Subject</td>
<td>The name of the task. A short description of what is to be done.</td>
</tr>
<tr>
<td>Owner</td>
<td>The person responsible for completing or following up on the task.</td>
</tr>
<tr>
<td>Notes</td>
<td>Details of the task. (optional)</td>
</tr>
<tr>
<td>Start Date</td>
<td>Expected or assigned start date. The bars on the Gantt chart require at least a start date.</td>
</tr>
<tr>
<td>Due Date</td>
<td>Expected completion date.</td>
</tr>
<tr>
<td>Date Completed</td>
<td>Actual completion date.</td>
</tr>
<tr>
<td>Status</td>
<td>There are several possible statuses in the drop down list, however the Gantt chart only recognizes ‘completed’ and ‘in progress’. Leave ‘not started’ statuses blank.</td>
</tr>
</tbody>
</table>

Gantt Chart
Gantt charts, named after Henry Gantt, display items spread over the time between two dates. In project management, they allow us to see the relationships between task time and the project as a whole. They can also provide a visual description of project completion.
Using Microsoft Office to Manage Projects

In our spreadsheet, each column represents one day. Weekends are grayed out. The day of the week is at the top. To conserve space, the date is in m/d/yy format. The first date is pumpkin colored. This field is unlocked. To use the Gantt chart, enter the Sunday of the week you want to start tracking. Typically, this is the week the project begins.

The horizontal bars crossing dates to the right correspond to the tasks at the left. Tasks that are completed are gray, in progress tasks are blue, and tasks yet to start are yellow. The right edge of the bar is defined by the due date until a completion date is entered.

The window has been ‘frozen’ at the left edge of the Gantt chart. Scrolling right moves along the dates, while the task information remains in place.

The figure below is an example of a spreadsheet with new project information entered.
Task Management in Outlook

Microsoft Outlook, in addition to Mail, Calendar, and Contacts, has a component called Tasks. Not only can it be used to create and track your tasks, it can be used to assign and track tasks you assign to others. It must, however, be customized to be useful for project task management.

Set up

This is the default, minimalist view. It is not particularly useful for managing tasks among different projects or different people, but is useful for managing personal tasks.

First, you will need the Advanced Toolbar. Go to View > Toolbars > Advanced.
Using Microsoft Office to Manage Projects

The Advanced Toolbar allows you to choose the view, enable the grouping bar, and open the field chooser without having to go to the menu or left navigation bar.

Open the field chooser and add the following fields: Company, Priority, Start Date, Date completed, Owner, Status, and % Complete. They can be arranged by dragging the label into position on the header bar. Once there, the labels can be dragged into whatever position is most useful to you.

Creating Tasks

The task information can now be entered and edited. These are the most common data elements for a task, however, if you want to see more, simply double-click on a task and a full Task window will open.

Note that date fields have a calendar control at the arrow and Status is a drop down list.

Tasks does not have a field called “Project”. Use the Company field to name the particular project.
Tasks can be sorted by clicking on any label. The arrow will show the direction of Sort (ascending or descending). In this image, the Owner is sorted in ascending order. You can also group on any label by dragging it to the Grouping area.

To separate by Project, drag the Company label into the Grouping area. This will allow you to see all of your tasks by project. If, instead of using the Company field, you decide to create a separate Tasks folder for each project, you won’t be able to see the tasks for all of your projects in one view. Keeping on top of the tasks will be more difficult.

When “completed” is picked in Status, % Complete becomes 100% and the entire line is crossed out.
Choosing “Task Timeline” view creates a Gantt chart of your project. The time periods are editable. Here, they are set at ‘Daily’.

Assigning and Tracking Tasks

Creating and tracking your own tasks is helpful, but if you are leading a project, you want to assign and track tasks for your entire team. The reason to use Outlook is that task management is integrated with email AND is not in a separate application like HyperOffice, but is already in an application you use daily.

As you create tasks, either from scratch or after importing them from Project_Template.xls (or MS Project for that matter), assigning them to team members within TransCare is as easy as right-clicking on the task and choosing ‘Assign Task’.

CAVEAT: Don't assign tasks in Outlook unless you know they are aware of how to use Tasks or you warn them and send a copy of this manual. You will probably cause a bit of confusion.
A Task Request opens that looks like a meeting appointment or email. Fill it out as you would an email by clicking the ‘To’ button and choosing a name from the Global Address Book.

If you haven’t already done so, enter a Due Date, Subject, and any details or notes related to the task. By default the ‘Keep an updated copy of this task on my task list’ and ‘Send me a status report when the task is complete’ boxes are checked. Leave them checked. Click ‘Send’.

This warning pops up to alert you to the fact that the task will now be ‘owned’ by the receiver. Any updates you enter will be over-ridden by the updates from the owner. This is fine. The task is still visible in your task list.
In fact, whenever the new task owner makes a change by entering notes or changing the completion percentage, you will get a notice in your email and the task in your task list will automatically update. Imagine how much easier on both of you this will be to keep abreast of the tasks in the project. It only requires a bit of discipline to make it a habit.

When the task owner finishes the task and checks the Complete box or changes the % Complete to 100%, you will get a final Status Report.
Communicating Progress

Tasks allows more than simply a beginning and an ending communication. By entering progress notes in the task, the task owner can keep the project leader up to date on the task without having to send emails or make phone calls. This image shows a new task. It has one line of notes to begin.

In the Details tab, the task creator estimated it will take one hour of work to complete the task. Organizations can use Tasks in Outlook to track expenses related to projects and allocate them to a specific department or bill clients.

Now, the task owner is entering an update. He is noting the task is approximately 10% complete and puts in a note. Unfortunately, he overwrote the original note.
Using Microsoft Office to Manage Projects

The task creator sees this after the task owner clicks ‘Save and Close’.

On the next update, the task owner adds a line before writing. This allows us to track the history of the task progress without having to look up earlier notes.

This is the task creator’s view. The task is 25% complete and all notes are visible. The task owner and task creator have communicated the task progress without really having to take time out to do so. If the Total Work and Actual Work fields are used, over time the project leader will have a better idea of how long certain tasks actually take and can better plan in the future.
Moving Tasks from Excel to Outlook

The Excel spreadsheet, Project_Template.xls, provides a means of planning and visualizing an entire project but can’t be used to communicate task assignment or progress. Outlook provides a means to assign and track specific tasks among team members but doesn’t facilitate planning or plan sharing. Wouldn’t it be great if they could be used together? They can. In fact, there are two ways to import tasks from Excel into Outlook without having to write a script in VBA. Which one you choose to use will be based on your comfort level in manipulating Excel spreadsheets.

**The Easier Way**

The easier of the two ways requires the user to define ‘named ranges’ within the spreadsheet which will necessitate turning off cell protection temporarily. Outlook does not support dynamic named ranges, a method of defining ranges by whether or not data exists in cells, so the spreadsheet cannot be set up with the named range as part of the template. If it was set up so, the user would have to delete all of the blank tasks that are created during the import process. Learning how to define the named range prior to importing will take less time.

First, unprotect the spreadsheet by going to the menu bar and choosing Tools > Protection > Unprotect Sheet. There is no password, so the sheet will immediately be unprotected.
Next, highlight the cells you want to import into Tasks, including the headers.

Once highlighted, go to the menu bar and choose Insert > Name > Define.

The Define Name window will open. Type a name in the ‘Names in workbook’ box that is NOT a column name. It can be anything that isn’t already in use.
Once completed, re-protect the spreadsheet by choosing Tools > Protection > Protect Sheet.

The Protect Sheet window will open. DO NOT enter a password. If you forget it, you’ll never be able to unprotect the spreadsheet. Leave all the permissions as is. Just click on the ‘OK’ button. The sheet is now protected again and you can close the spreadsheet.
Using Microsoft Office to Manage Projects

Go to your Tasks window in Outlook. (Note: the use of a folder called ‘My Tasks’ is for illustration only.)

On the menu bar, choose File > Import and Export.

The Import and Export Wizard will open. Choose ‘Import from another program or file” and click the ‘Next’ button.
Choose ‘Microsoft Excel’ and click the ‘Next’ button.

The Import a File window opens. Click the ‘Browse’ button to navigate to the file you want to import. Highlight it and click the ‘OK’ button (or double-click on the file).
Using Microsoft Office to Manage Projects

Select the destination folder. Choose ‘Tasks’. Then click the ‘Next’ button.

Outlook will see that there are two named ranges and you will have to choose which one to import by checking the appropriate box. (Note: ‘Stati’ is the name of the dropdown list for Status in the spreadsheet.) Then, click the ‘Map Custom Fields’ button to ensure your columns will be recognized and imported into the correct fields in Task.

Scroll down the window on the right to make sure your columns have a destination field. Owner cannot be imported into Tasks. If one of the other columns isn’t aligned with a field…
…simply click on the column name on the left and drag it over the field name on the right. Once mapping is complete, click ‘OK’.

Click the ‘Finish’ button.

Your tasks from the spreadsheet are imported and mapped to the correct Task field.
Using Microsoft Office to Manage Projects

Add the project name under Company. Now you can assign tasks to your team.

**The Harder Way**
Since Outlook requires Excel to have named ranges for importing, if you don’t want to name ranges, you have to save the Excel spreadsheet as something else. We will convert Excel to Comma Separated Values (.csv) to facilitate the import process. We don’t want all the columns, most of which are days in the Gantt chart, so we will copy the data we want and paste it into a new spreadsheet.

Highlight the cells you want to import, including the headers.
Open a new workbook and paste the data in cell A1. Don’t worry about formatting; we won’t be using this spreadsheet for anything except transferring the data to Outlook.

Save the new workbook with any name you will remember. Under ‘Save as type:’ choose “CSV (Comma delimited)(* .csv)”. Excel will warn you that CSV doesn’t support multiple sheets. That’s okay, you are only using the first one. Click ‘OK’.

Excel will now warn you that not all features (like formulas) are compatible with CSV. That’s okay, too. Click ‘Yes’.
Using Microsoft Office to Manage Projects

Now, close the file. When asked if you want to save, click ‘No’. If you click ‘Yes’, you will have to go through the same save process and questions as you just completed.

Go to Tasks in Outlook and choose File > Import and Export from the menu bar.

Choose ‘Import from another program or file’ and click ‘Next’.
Choose ‘Comma Separated Values (Windows)’ and click ‘Next’.

Find the file by clicking the ‘Browse’ button and navigating to the file.

Select the Tasks folder as the destination.
Using Microsoft Office to Manage Projects

Click the ‘Map Custom Fields’ button to ensure your columns will be inserted into the correct Task fields.

Scroll down the window on the right to make sure your columns have a destination field. Owner cannot be imported into Tasks. If one of the other columns isn’t aligned with a field...

...simply click on the column name on the left and drag it over the field name on the right. Once mapping is complete, click ‘OK’. Click ‘Finish’ on the Import Wizard window.
Your tasks from the spreadsheet are imported and mapped to the correct Task field.

Add the project name under Company. Now you can assign tasks to your team.